PretendPrusa

PretendPrusa => Pretend Prusa Chitchat => Topic started by: CdRsKuLL on June 26, 2019, 05:55:07 PM

Title: Waggster BLTouch V1.0
Post by: CdRsKuLL on June 26, 2019, 05:55:07 PM
Waggster BLTouch V1.0

https://pretendprusa.co.uk/index.php?action=downloads;sa=view;down=9 (https://pretendprusa.co.uk/index.php?action=downloads;sa=view;down=9)

BLTouch for the Artillery Sidewinder X1

The download link is just above... :-)

Expected upgrade time 30 minutes
Technical level - medium

(https://pretendprusa.co.uk/files/Waggster_Web.jpg)

Includes
BLTouch LED wires mod
MKS Gen L1.0 Marlin 1.19 / 2.0 Firmware (recommended)
MKS 2.8 TFT LCD Firmware
PrusaSlicer Profiles

Please read the included PDF and watch the video below.

Title: Re: Waggster BLTouch V1.0
Post by: gfetters on October 05, 2019, 07:41:16 PM
This is an excellent mod!  I liked the led but the bltouch will be a much better option.  I have tried the upgrade but I am getting an odd problem and I hope you can help.  The Z axis stops and will not go down to the bed.  You can't manually adjust it down either.  The bltouch makes a clicking sound too.  I am thinking that I have one of the wires wrong plugged in wrong on the effector.  would you show a photo of the order and color connected to the bl touch and where the brown wires attach on the mks gen l?
Title: Re: Waggster BLTouch V1.0
Post by: gfetters on October 06, 2019, 04:44:42 PM
I was able to figure out my issue with the bl touch.  My Brown cable was wired backwards.  So if the bl touch does not light when you first turn it on reverse the brown wires that are plugged in to the first servo slot.
Title: Re: Waggster BLTouch V1.0
Post by: NealR54 on October 24, 2019, 05:02:57 PM
So I am a relative newbie with my new Sidewinder. Unfortunately I am on a Mac platform and can't unzip the files that I downloaded. Is there an easy way to do this, or do I need to be on a Windows platform to do the mod?
Title: Re: Waggster BLTouch V1.0
Post by: JaySmith on October 27, 2019, 01:55:17 PM
This is such a great mod, and the video is well done.  Much appreciated! 
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on November 04, 2019, 01:43:01 AM
So I am a relative newbie with my new Sidewinder. Unfortunately I am on a Mac platform and can't unzip the files that I downloaded. Is there an easy way to do this, or do I need to be on a Windows platform to do the mod?

I've no idea to be honest, never owned a MAC but I would have thought you could at least get a unzip program for it?
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on November 04, 2019, 01:43:28 AM
This is such a great mod, and the video is well done.  Much appreciated!

Thanks fella,  very much appreciated :-)
Title: Re: Waggster BLTouch V1.0
Post by: Chazy on November 12, 2019, 04:13:05 AM
Hello. I follow your fantastic guide and works perfectly! My first layer is so lovely!
But I have a problem: after upgrading firmware to Marlin 2.0, at some point while printing (like 70%), my printer blocks. I don't know if it's a firmware related (I used the marlin 2.0)..
Do you have same problem?!
Title: Re: Waggster BLTouch V1.0
Post by: Chazy on November 12, 2019, 04:14:16 AM
Hello. I follow your fantastic guide and works perfectly! My first layer is so lovely!
But I have a problem: after upgrading firmware to Marlin 2.0, at some point while printing (like 70%), my printer blocks. I don't know if it's a firmware related (I used the marlin 2.0)..
Do you have same problem?!
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on November 18, 2019, 04:17:46 AM
Hi,

No I've not had that problem but it sounds like heat creep maybe or bad filament.   Feel your extruder motor if it happens again to see if its hot. You might need to adjust the vref on the driver a little.  Also double check your extruder fan is working correctly.
Title: Re: Waggster BLTouch V1.0
Post by: Mutiusm on December 01, 2019, 07:05:00 PM
Hi, I have followed your ABL tip and installed a BL-touch, everything went fine except I mounted the probe with a different holding system. Now my probe is 58mm left and 36mm in the front of the nozzle. You compiled Marlin 2.0 for your placing of the probe. I am now trying to recompile Marlin but have platformio somehow hanging...:-(  :-[ could you eventually compile another version for me ? That would be great.

 Thanks Matthias
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on December 02, 2019, 02:38:04 AM
I just use the Arduino IDE to compile, its nice and simple. :-)

You will also need to play around with the probe points in the firmware as these will change. Also, in the settings.txt file in the touchscreen firmware you need to change the offset point so it performs the Z offset in the middle of the bed.

Have a go through the Arduino IDE..  I'm really busy at the moment but give that a go and let me know how you get on.

Steve
Title: Re: Waggster BLTouch V1.0
Post by: mavericm1 on December 02, 2019, 07:53:01 PM
Planning on using this guide along with the new hemera guide at https://e3d-online.dozuki.com/Guide/Hemera+Artillery+(Evnovo)+Sidewinder+X1+Firmware+Modification/121?lang=en   after installing my hemera and bltouch will have to figure out the new offset for the probe but hopefully will not be too bad.   Thanks for posting this.
Title: Re: Waggster BLTouch V1.0
Post by: Keo on December 09, 2019, 09:04:44 PM
I tried to follow this mod but inside my Sidewinder x1 I don't have a 3 cable brown wire.  What I have are 3 single wires one red, one blue, and one green.

So I guessed as to how the wires lined up and my bltouch lights up but I can't get it to deploy.  It's also flashing red.

Any advice?

Also, where in the firmware is the bltouch configured so it is deployed as a probe with that pin layout?  In the past I've just replaced my z end stop with the bltouch so I wired it to the end stop terminal.
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on December 11, 2019, 11:43:50 AM
Hey Keo,

Just flip your 3 wire plug 180 degrees around and try that. You won't cause any damage as it's the center pin that's positive and that doesn't move.

In my firmware, I swapped the Z min to the Z max pin so it saves you unplugging it. From memory it's in the ramps.pin code.. think its pin 18 to 19 or something like that.

Chances are just rotating your 3 pin plug around will solve your problem.

Let me know how you get on,

Steve

 
Title: Re: Waggster BLTouch V1.0
Post by: jakekooser on December 13, 2019, 09:54:19 PM
Hi there,

Just wanted to say thank you for an outstanding mod.  I was able to get mine set up according to the .pdf file but it seems as though my Z axis might be creeping a bit due to heat cycles.  I loaded the Marlin 2.0 BL Touch.hex file and I am able to do the z-offset but when I go to do my first print, I don't have the 'baby steps' option available anywhere on the touch screen.  I am using Octoprint, could that be the issue?

Thanks
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on December 14, 2019, 06:25:47 AM
Hi, thanks for the comments.  Yes, you are correct in that octoprint talks directly to the mainboard and bypasses the touchscreen so no options will show. I would do a print from the usb via the touchscreen just to tune your z-offset then swap back to your octoprint pi. :-)

Steve
Title: Re: Waggster BLTouch V1.0
Post by: jakekooser on December 14, 2019, 09:34:17 AM
That did the trick, thank you!
Title: Re: Waggster BLTouch V1.0
Post by: TPJensen on January 25, 2020, 06:50:04 PM
Thanks for this great guide  :) 8)

I have made the update to the Sidewinder x1 and got it to work after some work, it was because my brown wires was backwards in the plug.

But I have 1 problem I cant solved so I can use the printer... When I start a print it level out bed no problems it start the print but when the part cooler start the bltouch activate on off on off and dont stop before fan if off or I stop the print and reset printer....

It also just happen when I manuel start the fan..

The problem is found and how wierd it sounds is fan the part cooler fan. Did put another one on and now it works fine.... the old one on again and problem again so the Fan

UPDATE

The Problem is still there on stock fan size 4020 But found out the if the fan runs MAX then no problem but under BLtouch act up
IF I use a 5015 fan instead then there is no problem on any speed...
Title: Re: Waggster BLTouch V1.0
Post by: Columbian on February 02, 2020, 03:42:56 PM
Hi all. I'm brand new to 3D printing. I am waiting for my Sidewinder X1 to arrive with the bltouch, hopefully tomorrow. I am wondering if there are any tips using version 4 of the Sidewinder. It looks like there might be some issues.
Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on February 03, 2020, 12:32:39 PM
Generally, the X-1 prints superb out of the box once you have levelled the bed. I would get a few prints done and maybe if you then think it's worth fitting a BL Touch then give it a go.. I wouldn't just jump straight in as sometimes your bed is that flat you don't need to. 

Any problems just ask away and I'll do my best to help you.

Happy printing :-)

Steve
Title: Re: Waggster BLTouch V1.0
Post by: Flipit on April 24, 2020, 11:54:34 PM
Great work.  This is an excellent tutorial.

I have just encountered one problem with setting the z offset with V1.5.  When I hit the start z offset button,  the extruder crashes into the bed.  I have done the setup multiple times using the disc to set the bltouch 4mm higher than the nozzle, but I get the same results. I can't see where I am going wrong.

I have kindof got it going now with the probe being at the same level as the nozzle,  but it of course catches the prints,  so not viable.

The probe is showing no errors (it's a 3dtouch).

Title: Re: Waggster BLTouch V1.0
Post by: CdRsKuLL on April 25, 2020, 01:35:20 AM
hmm it sounds like the BL Touch isn't triggering.  I would try flipping one of the 3 pin plugs around.. also make sure you have your signal wire attached to the Z max signal pin. If you can take photos that may help?
Title: Re: Waggster BLTouch V1.0
Post by: jonmcclay on June 13, 2020, 09:59:56 AM
I ordered this BLtouch https://www.amazon.com/gp/product/B07GVCX74T (https://www.amazon.com/gp/product/B07GVCX74T) from Amazon

After following the guide I discovered that the device needs a male-male connector for the LED connection. One user at the Facebook Group for Artillery Modifications recommended this part:
https://www.amazon.com/gp/product/B00U8OCENY (https://www.amazon.com/gp/product/B00U8OCENY)

The fans need longer screws as well, I bought this kit since I will probably be needing them in the future. Also the kit includes the right screw for the vertical adjustment of the BLtouch:
https://www.amazon.com/gp/product/B07H4MG7TC (https://www.amazon.com/gp/product/B07H4MG7TC)