PretendPrusa

PretendPrusa => Pretend Prusa Firmware => Topic started by: marcomomsen on April 12, 2020, 04:57:18 AM

Title: ABL actually not working ?
Post by: marcomomsen on April 12, 2020, 04:57:18 AM

After enabling G26 (ABL Test print pattern) I realised that the build actually does not compensate at all. Marlin GIT is full of poeple complaining that ABL actually doesnt work. It doesn't seem to work on this build either. Can you verify by enabling G26 ? Slighlty creating an uneven bed shows more clearly.

https://github.com/MarlinFirmware/Marlin/issues/16397
Title: Re: ABL actually not working ?
Post by: marcomomsen on April 12, 2020, 05:03:59 AM
Also : https://github.com/MarlinFirmware/Marlin/issues/17399
Title: Re: ABL actually not working ?
Post by: CdRsKuLL on April 17, 2020, 05:37:07 AM
When printing you can actually feel the Z axis moving to compensate for the bed.  I don't use G26 so can't comment on that sorry
Title: Re: ABL actually not working ?
Post by: marcomomsen on April 17, 2020, 07:29:17 AM
Well G26 pretty clearly prooves that it doesn't. That's what it is meant for.
Can you enable G26 and G34 in your next builds please? Thanks :)
Title: Re: ABL actually not working ?
Post by: CdRsKuLL on April 17, 2020, 01:28:16 PM
Well G26 pretty clearly prooves that it doesn't. That's what it is meant for.
Can you enable G26 and G34 in your next builds please? Thanks :)

Hi, I'll have a look at the G26 command for you, never used it to be honest. The G34 could damage the X1 and Genius due to the Z-axis being tied together and should not need this command unless I'm not understanding it correctly?

Steve
Title: Re: ABL actually not working ?
Post by: marcomomsen on May 09, 2020, 06:10:53 AM
For G34 one would need to have removed the belt and have a level bed, indeed, it doesn't seem to make much sense.